Tyler Wojciechowicz

I'm looking to program my RTL8195 using the Arduino IDE but am having consistent issues. I have tried multiple USB cables, ports and even have two RTL8195 devices. I have also restarted my computer numerous times. I have also experimented with having an additional USB power input plugged in before and after the DAP USB cable is plugged in to no avail.

I'm running Win 10.

Whenever I plug in a RTL8195, the device appears as a COM port in device manager "mbed Serial Port." It also opens a new drive on my PC "D:/" and some mbed files show up. Approximately 10 seconds later, the device disappears from the COM ports and I get a prompt saying "USB device not recognized." Under general USB controllers the device shows up as "Unknown USB Device (Device Descriptor Request Failed)." 10 seconds later, my device manager refreshes and a second "Unknown USB Device (Device Descriptor Request Failed)" component shows up. After this there are no other changes recognized by my device manager.

I have tried multiple drivers, uninstalling before each instance. I have also successfully installed the drivers from here:


What could possibly be the issue? Thanks in advance.

Tyler Wojciechowicz 已回應